File qt6-lottie.spec of Package qt6-lottie
129
1
#
2
# spec file for package qt6-lottie
3
#
4
# Copyright (c) 2022 SUSE LLC
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
%define real_version 6.4.2
20
%define short_version 6.4
21
%define short_name qtlottie
22
%define tar_name qtlottie-everywhere-src
23
%define tar_suffix %{nil}
24
#
25
%global qt6_flavor @BUILD_FLAVOR@%{nil}
26
%if "%{qt6_flavor}" == "docs"
27
%define pkg_suffix -docs
28
%endif
29
#
30
Name: qt6-lottie%{?pkg_suffix}
31
Version: 6.4.2
32
Release: 0
33
Summary: QML API for rendering graphics and animation
34
# LICENSE.GPL3-EXCEPT only applies to the conan recipe which is not used
35
License: GPL-3.0-or-later
36
URL: https://www.qt.io
37
Source: https://download.qt.io/official_releases/qt/%{short_version}/%{real_version}%{tar_suffix}/submodules/%{tar_name}-%{real_version}%{tar_suffix}.tar.xz
38
Source99: qt6-lottie-rpmlintrc
39
BuildRequires: pkgconfig
40
BuildRequires: qt6-gui-private-devel
41
BuildRequires: cmake(Qt6Core)
42
BuildRequires: cmake(Qt6Gui)
43
BuildRequires: cmake(Qt6Qml)
44
BuildRequires: cmake(Qt6Quick)
45
BuildRequires: cmake(Qt6QuickTest)
46
%if "%{qt6_flavor}" == "docs"
47
BuildRequires: qt6-tools
48
%{qt6_doc_packages}
49
%endif
50
51
%description
52
Qt Lottie Animation provides a QML API for rendering graphics and animations
53
that are exported in JSON format by the Bodymovin plugin.
54
55
%if !%{qt6_docs_flavor}
56
57
%package imports
58
Summary: Qt 6 Lottie QML files and plugins
59
60
%description imports
61
QML files and plugins from the Qt 6 Lottie module.
62
63
### Private only library ###
64
65
%package -n libQt6Bodymovin6
66
Summary: Qt 6 Bodymovin library
67
68
%description -n libQt6Bodymovin6
69
The Qt 6 Bodymovin library.
70
This library does not have any ABI or API guarantees.
71
72
%package -n qt6-bodymovin-private-devel
73
Summary: Development files for the Qt 6 Bodymovin library
74
Requires: cmake(Qt6BodymovinPrivate) = %{real_version}
75
Requires: cmake(Qt6Gui)
76
# Renamed in 6.2.0
77
Provides: qt6-bodymovin-devel = 6.2.0
78
Obsoletes: qt6-bodymovin-devel < 6.2.0
79
80
%description -n qt6-bodymovin-private-devel
81
This package provides private headers of libQt6Bodymovin that do not have any
82
ABI or API guarantees.
83
84
%endif
85
86
%prep
87
%autosetup -p1 -n %{tar_name}-%{real_version}%{tar_suffix}
88
89
%build
90
%cmake_qt6
91
92
%{qt6_build}
93
94
%install
95
%{qt6_install}
96
97
%if !%{qt6_docs_flavor}
98
99
# CMake files are not needed for plugins
100
rm -r %{buildroot}%{_qt6_cmakedir}/Qt6Qml/QmlPlugins
101
102
%post -n libQt6Bodymovin6 -p /sbin/ldconfig
103
%postun -n libQt6Bodymovin6 -p /sbin/ldconfig
104
105
%files imports
106
%dir %{_qt6_qmldir}/Qt
107
%dir %{_qt6_qmldir}/Qt/labs
108
%{_qt6_qmldir}/Qt/labs/lottieqt/
109
110
%files -n libQt6Bodymovin6
111
%license LICENSES/*
112
%{_qt6_libdir}/libQt6Bodymovin.so.*
113
114
### Private only library ###
115
116
%files -n qt6-bodymovin-private-devel
117
%{_qt6_cmakedir}/Qt6BodymovinPrivate/
118
%{_qt6_cmakedir}/Qt6BuildInternals/StandaloneTests/QtLottieTestsConfig.cmake
119
%{_qt6_descriptionsdir}/BodymovinPrivate.json
120
%{_qt6_includedir}/QtBodymovin/
121
%{_qt6_libdir}/libQt6Bodymovin.prl
122
%{_qt6_libdir}/libQt6Bodymovin.so
123
%{_qt6_metatypesdir}/qt6bodymovinprivate_*_metatypes.json
124
%{_qt6_mkspecsdir}/modules/qt_lib_bodymovin_private.pri
125
126
%endif
127
128
%changelog
129