File libhdhomerun.spec of Package libhdhomerun
162
1
#
2
# spec file for package libhdhomerun
3
#
4
# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
%define SO_NR 2
20
Name: libhdhomerun
21
Version: 20190621
22
Release: 0
23
Summary: HDHomeRun library
24
License: LGPL-2.1-only
25
Group: Productivity/Other
26
URL: http://www.silicondust.com
27
Source0: http://download.silicondust.com/hdhomerun/libhdhomerun_%{version}.tgz
28
Source1: http://download.silicondust.com/hdhomerun/hdhomerun_config_gui_%{version}.tgz
29
Source2: hdhomerun_config_gui.desktop
30
Source3: hdhomerun_config_gui.png
31
Patch0: Makefile.patch
32
BuildRequires: gcc-c++
33
BuildRequires: gtk2-devel
34
BuildRequires: pkgconfig
35
BuildRequires: update-desktop-files
36
37
%description
38
HDHomeRun configuration library allows you to discover HDHomeRun ATSC/QAM/DVB
39
TV tuners on the network. It can configure the tuners, scan for channels, and
40
retrieve information, including signal strength. A shared library is included
41
for linking by client applications and a simple console application is included
42
for scripting.
43
44
%package -n libhdhomerun%{SO_NR}
45
Summary: HDHomeRun library
46
License: LGPL-2.1-only
47
Group: Productivity/Other
48
49
%description -n libhdhomerun%{SO_NR}
50
HDHomeRun configuration library allows you to discover HDHomeRun ATSC/QAM/DVB
51
TV tuners on the network. It can configure the tuners, scan for channels, and
52
retrieve information, including signal strength. A shared library is included
53
for linking by client applications and a simple console application is included
54
for scripting.
55
56
%package devel
57
Summary: HDHomeRun library
58
License: LGPL-2.1-only
59
Group: Development/Libraries/Other
60
Requires: libhdhomerun%{SO_NR} = %{version}
61
Provides: libhdhomerun:%{_includedir}/libhdhomerun/hdhomerun.h
62
63
%description devel
64
Development libraries needed to build applications with libhdhomerun.
65
66
%package -n hdhomerun_config
67
Summary: HDHomeRun Config tool
68
License: LGPL-2.1-only
69
Group: Productivity/Other
70
71
%description -n hdhomerun_config
72
hdhomerun_config is a command line tool to discover, configure, and scan
73
HDHomeRun TV tuners. The tool can also be used to update the tuner's firmware.
74
75
Firmware updates can be downloaded from http://www.silicondust.com/support/hdhomerun/downloads/linux
76
77
%package -n hdhomerun_config_gui
78
Summary: HDHomeRun GTK GUI
79
License: GPL-3.0-only
80
Group: Productivity/Other
81
Requires: libhdhomerun%{SO_NR} = %{version}
82
83
%description -n hdhomerun_config_gui
84
The HDHomeRun Config GUI is a GUI tool to discover, configure, and scan
85
HDHomeRun TV tuners. The tool can also be used to update the tuner's firmware.
86
87
Firmware updates can be downloaded from http://www.silicondust.com/support/hdhomerun/downloads/linux
88
89
%prep
90
%setup -q -b 1 -n hdhomerun_config_gui
91
cd ../libhdhomerun
92
%patch0
93
94
%build
95
ln -s libhdhomerun.so.%{SO_NR} ../libhdhomerun/libhdhomerun.so
96
%configure
97
make %{?_smp_mflags} all
98
99
%install
100
mkdir -p %{buildroot}/%{_bindir}
101
mkdir -p %{buildroot}/%{_libdir}
102
mkdir -p %{buildroot}/%{_includedir}/libhdhomerun
103
104
# hdhomerun_config_gui
105
cp src/hdhomerun_config_gui %{buildroot}/%{_bindir}
106
107
cd ../libhdhomerun
108
109
# libraries
110
cp libhdhomerun.so.%{SO_NR} %{buildroot}/%{_libdir}
111
ln -s libhdhomerun.so.%{SO_NR} %{buildroot}/%{_libdir}/libhdhomerun.so
112
113
# binaries
114
cp hdhomerun_config %{buildroot}/%{_bindir}
115
116
# headers
117
cp hdhomerun.h %{buildroot}/%{_includedir}/libhdhomerun
118
cp hdhomerun_os.h %{buildroot}/%{_includedir}/libhdhomerun
119
cp hdhomerun_os_posix.h %{buildroot}/%{_includedir}/libhdhomerun
120
cp hdhomerun_types.h %{buildroot}/%{_includedir}/libhdhomerun
121
cp hdhomerun_pkt.h %{buildroot}/%{_includedir}/libhdhomerun
122
cp hdhomerun_sock.h %{buildroot}/%{_includedir}/libhdhomerun
123
cp hdhomerun_debug.h %{buildroot}/%{_includedir}/libhdhomerun
124
cp hdhomerun_discover.h %{buildroot}/%{_includedir}/libhdhomerun
125
cp hdhomerun_control.h %{buildroot}/%{_includedir}/libhdhomerun
126
cp hdhomerun_video.h %{buildroot}/%{_includedir}/libhdhomerun
127
cp hdhomerun_channels.h %{buildroot}/%{_includedir}/libhdhomerun
128
cp hdhomerun_channelscan.h %{buildroot}/%{_includedir}/libhdhomerun
129
cp hdhomerun_device.h %{buildroot}/%{_includedir}/libhdhomerun
130
cp hdhomerun_device_selector.h %{buildroot}/%{_includedir}/libhdhomerun
131
132
# desktop stuff
133
mkdir -p %{buildroot}/%{_datadir}/icons/hicolor/32x32/apps
134
cp %{SOURCE3} %{buildroot}/%{_datadir}/icons/hicolor/32x32/apps
135
136
mkdir -p %{buildroot}/%{_datadir}/applications
137
cp %{SOURCE2} %{buildroot}/%{_datadir}/applications
138
%suse_update_desktop_file hdhomerun_config_gui
139
140
%post -n libhdhomerun%{SO_NR} -p /sbin/ldconfig
141
%postun -n libhdhomerun%{SO_NR} -p /sbin/ldconfig
142
143
%files -n libhdhomerun%{SO_NR}
144
%attr(0755,root,root) %{_libdir}/libhdhomerun.so.%{SO_NR}*
145
%license ../libhdhomerun/LICENSE
146
%doc ../libhdhomerun/README.md
147
148
%files devel
149
%{_includedir}/libhdhomerun
150
%{_libdir}/libhdhomerun.so
151
152
%files -n hdhomerun_config
153
%{_bindir}/hdhomerun_config
154
155
%files -n hdhomerun_config_gui
156
%attr(0755,root,root) %{_bindir}/hdhomerun_config_gui
157
%{_datadir}/applications/hdhomerun_config_gui.desktop
158
%{_datadir}/icons/hicolor/32x32/apps/hdhomerun_config_gui.png
159
%license COPYING
160
161
%changelog
162