File yast2-nfs-client.spec of Package yast2-nfs-client
106
1
#
2
# spec file for package yast2-nfs-client
3
#
4
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
Name: yast2-nfs-client
20
Version: 4.0.8
21
Release: 0
22
Url: https://github.com/yast/yast-nfs-client
23
24
BuildRoot: %{_tmppath}/%{name}-%{version}-build
25
Source0: %{name}-%{version}.tar.bz2
26
27
BuildRequires: perl-XML-Writer
28
BuildRequires: update-desktop-files
29
BuildRequires: yast2-devtools >= 3.1.27
30
BuildRequires: yast2-testsuite
31
# SuSEFirewall2 replaced by firewalld (fate#323460)
32
BuildRequires: yast2 >= 4.0.39
33
BuildRequires: rubygem(rspec)
34
#for install task
35
BuildRequires: rubygem(%rb_default_ruby_abi:yast-rake)
36
# path_matching (RSpec argument matcher)
37
BuildRequires: yast2-ruby-bindings >= 3.1.31
38
# SuSEFirewall2 replaced by firewalld (fate#323460)
39
Requires: yast2 >= 4.0.39
40
#idmapd_conf agent
41
Requires: yast2-nfs-common >= 2.24.0
42
# showmount, #150382, #286300
43
Recommends: nfs-client
44
# Y2Storage::MountPoint#active=
45
Requires: yast2-storage-ng >= 4.0.180
46
# Y2Storage::MountPoint#active=
47
BuildRequires: yast2-storage-ng >= 4.0.180
48
49
# Unfortunately we cannot move this to macros.yast,
50
# bcond within macros are ignored by osc/OBS.
51
%bcond_with yast_run_ci_tests
52
%if %{with yast_run_ci_tests}
53
BuildRequires: rubygem(yast-rake-ci)
54
%endif
55
56
Provides: yast2-config-nfs
57
Provides: yast2-config-nfs-devel
58
Obsoletes: yast2-config-nfs
59
Obsoletes: yast2-config-nfs-devel
60
Provides: yast2-trans-nfs
61
Obsoletes: yast2-trans-nfs
62
Provides: yast2-config-network:/usr/lib/YaST2/clients/lan_nfs_client.ycp
63
64
BuildArch: noarch
65
66
Requires: yast2-ruby-bindings >= 1.0.0
67
68
Summary: YaST2 - NFS Configuration
69
License: GPL-2.0-or-later
70
Group: System/YaST
71
72
%description
73
The YaST2 component for configuration of NFS. NFS stands for network
74
file system access. It allows access to files on remote machines.
75
76
%prep
77
%setup -n %{name}-%{version}
78
79
%build
80
81
%check
82
rake test:unit
83
84
%install
85
rake install DESTDIR="%{buildroot}"
86
87
%files
88
%defattr(-,root,root)
89
%dir %{yast_yncludedir}/nfs
90
%{yast_yncludedir}/nfs/*
91
%dir %{yast_clientdir}
92
%{yast_clientdir}/nfs.rb
93
%{yast_clientdir}/nfs-client.rb
94
%{yast_clientdir}/nfs_auto.rb
95
%{yast_clientdir}/nfs-client4part.rb
96
%dir %{yast_moduledir}
97
%{yast_moduledir}/Nfs.rb
98
%{yast_moduledir}/NfsOptions.rb
99
%{yast_dir}/lib/y2nfs_client
100
%dir %{yast_desktopdir}
101
%{yast_desktopdir}/nfs.desktop
102
%doc %{yast_docdir}
103
%{yast_schemadir}/autoyast/rnc/nfs.rnc
104
105
%changelog
106