File libcacard.spec of Package libcacard (Revision 45eac30e42f76fd36798dd7b69f4d26f)
Currently displaying revision 45eac30e42f76fd36798dd7b69f4d26f , Show latest
112
1
#
2
# spec file for package libcacard
3
#
4
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
Name: libcacard
20
Url: http://cgit.freedesktop.org/spice/libcacard/
21
Summary: Common Access Card (CAC) emulation
22
License: LGPL-2.1+
23
Group: System/Emulators/PC
24
Version: 2.5.3
25
Release: 1.27
26
Source: http://www.spice-space.org/download/libcacard/libcacard-%{version}.tar.xz
27
BuildRoot: %{_tmppath}/%{name}-%{version}-build
28
BuildRequires: glib2-devel
29
BuildRequires: mozilla-nss-devel
30
BuildRequires: pkg-config
31
%if 0%{?suse_version} < 1210
32
BuildRequires: xz
33
%endif
34
Provides: qemu-tools:%{_bindir}/vscclient
35
36
%description
37
This emulator is designed to provide emulation of actual smart cards to a
38
virtual card reader running in a guest virtual machine. The emulated smart
39
cards can be representations of real smart cards, where the necessary functions
40
such as signing, card removal/insertion, etc. are mapped to real, physical
41
cards which are shared with the client machine the emulator is running on, or
42
the cards could be pure software constructs.
43
44
%package -n libcacard0
45
Summary: Common Access Card (CAC) emulation
46
Group: System/Emulators/PC
47
48
%description -n libcacard0
49
This emulator is designed to provide emulation of actual smart cards to a
50
virtual card reader running in a guest virtual machine. The emulated smart
51
cards can be representations of real smart cards, where the necessary functions
52
such as signing, card removal/insertion, etc. are mapped to real, physical
53
cards which are shared with the client machine the emulator is running on, or
54
the cards could be pure software constructs.
55
56
%package devel
57
Summary: Common Access Card (CAC) emulation -- Development files
58
Group: Development/Languages/C and C++
59
Requires: glib2-devel
60
Requires: libcacard0 = %version
61
Requires: mozilla-nspr
62
Requires: mozilla-nss
63
64
%description devel
65
This emulator is designed to provide emulation of actual smart cards to a
66
virtual card reader running in a guest virtual machine. The emulated smart
67
cards can be representations of real smart cards, where the necessary functions
68
such as signing, card removal/insertion, etc. are mapped to real, physical
69
cards which are shared with the client machine the emulator is running on, or
70
the cards could be pure software constructs.
71
72
This sub-package contains development files for the Smartcard library.
73
74
%prep
75
%setup -q
76
77
%build
78
%configure
79
make %{?_smp_mflags} V=1
80
81
%install
82
make install DESTDIR=%{buildroot}
83
rm -f %{buildroot}%{_libdir}/libcacard.a
84
rm -f %{buildroot}%{_libdir}/libcacard.la
85
86
%post -n libcacard0 -p /sbin/ldconfig
87
88
%postun -n libcacard0 -p /sbin/ldconfig
89
90
%files
91
%defattr(-, root, root)
92
%{_bindir}/vscclient
93
94
%files -n libcacard0
95
%defattr(-, root, root)
96
%{_libdir}/libcacard.so.0*
97
98
%files devel
99
%defattr(-, root, root)
100
%dir %{_includedir}/cacard
101
%{_includedir}/cacard/*.h
102
%{_libdir}/libcacard.so
103
%{_libdir}/pkgconfig/libcacard.pc
104
105
%changelog
106
* Wed May 3 2017 brogers@suse.com
107
- Update to v2.5.3
108
* Includes fix for host memory leakage while creating new APDU
109
(CVE-2017-6414 boo#1027514)
110
* Tue Jan 19 2016 afaerber@suse.de
111
- Initial - split out from QEMU
112