File dpdk-thunderx.spec of Package dpdk
398
1
#
2
# spec file for package dpdk-thunderx
3
#
4
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
# needssslcertforbuild
18
19
20
%define machine native
21
%define machine2 default
22
%ifarch x86_64
23
%define machine native
24
%define target x86_64-%{machine}-linuxapp-gcc
25
%endif
26
%ifarch %{ix86}
27
%define machine native
28
%define target i686-%{machine}-linuxapp-gcc
29
%endif
30
%ifarch aarch64
31
%define machine2 thunderx
32
%define target arm64-%{machine2}-linuxapp-gcc
33
%endif
34
%ifarch ppc64le
35
%define machine2 power8
36
%define target ppc_64-%{machine2}-linuxapp-gcc
37
%endif
38
%bcond_without shared
39
# Add option to build without examples
40
%bcond_without examples
41
# Add option to build without tools
42
%bcond_without tools
43
44
# The lname versioning is based solely on the MAJOR and MINOR
45
# as per DPDK CONFIG_RTE_MAJOR_ABI.
46
%define lname libdpdk-17_11-0
47
48
# Do NOT edit this auto generated file! Edit dpdk.spec instead
49
# and run 'pre_checkin.sh' before committing
50
Name: dpdk-thunderx
51
Version: 17.11.2
52
Release: 0
53
Summary: Set of libraries and drivers for fast packet processing (thunderx)
54
License: BSD-3-Clause AND GPL-2.0-only AND LGPL-2.1-only
55
Group: System/Libraries
56
Url: http://dpdk.org
57
Source: http://fast.dpdk.org/rel/dpdk-%{version}.tar.xz
58
Source1: preamble
59
# PATCH-FIX-OPENSUSE 0001-enic-fix-Type-punning-and-strict-aliasing-warning.patch
60
# This patch was originally taken from the fedora package but they have
61
# removed it since then because of
62
# http://osdir.com/ml/scm-fedora-commits/2016-03/msg00849.html
63
# However, the problem still exists and the fix has to find its way to the
64
# upstream code.
65
Patch1: 0001-enic-fix-Type-punning-and-strict-aliasing-warning.patch
66
BuildRequires: doxygen
67
BuildRequires: fdupes
68
BuildRequires: libelf-devel
69
BuildRequires: libnuma-devel
70
BuildRequires: libpcap-devel
71
BuildRequires: pesign-obs-integration
72
BuildRequires: rdma-core-devel
73
BuildRequires: zlib-devel
74
ExclusiveArch: aarch64
75
Provides: dpdk-any = %{version}
76
Conflicts: otherproviders(dpdk-any)
77
78
%description
79
The Data Plane Development Kit is a set of libraries and drivers for
80
fast packet processing in the user space.
81
82
%package devel
83
Summary: Data Plane Development Kit development files (thunderx)
84
Group: Development/Libraries/C and C++
85
Requires: %{lname} = %{version}
86
Provides: dpdk-any-devel = %{version}
87
Conflicts: otherproviders(dpdk-any-devel)
88
89
%description devel
90
This package contains the headers and other files needed for developing
91
applications with the Data Plane Development Kit.
92
93
%package -n %{lname}
94
Summary: Data Plane Development Kit runtime libraries (thunderx)
95
Group: Development/Libraries/C and C++
96
Provides: %{lname}-any = %{version}
97
98
%description -n %{lname}
99
This package contains the runtime libraries needed for 3rd party application
100
to use the Data Plane Development Kit.
101
102
%package doc
103
Summary: Data Plane Development Kit API documentation (thunderx)
104
Group: System/Libraries
105
BuildArch: noarch
106
Provides: dpdk-any-doc = %{version}
107
Conflicts: otherproviders(dpdk-any-doc)
108
109
%description doc
110
API programming documentation for the Data Plane Development Kit.
111
112
%if %{with tools}
113
%package tools
114
Summary: Tools for setting up Data Plane Development Kit environment (thunderx)
115
Group: System/Libraries
116
Requires: %{name} = %{version}
117
Requires: findutils
118
Requires: iproute
119
Requires: kmod
120
Requires: pciutils
121
Provides: dpdk-any-tools = %{version}
122
Conflicts: otherproviders(dpdk-any-tools)
123
124
%description tools
125
This package contains tools for setting up Data Plane Development Kit environment
126
%endif
127
128
%if %{with examples}
129
%package examples
130
Summary: Data Plane Development Kit example applications (thunderx)
131
Group: System/Libraries
132
BuildRequires: libvirt-devel
133
Provides: dpdk-any-examples = %{version}
134
Conflicts: otherproviders(dpdk-any-examples)
135
136
%description examples
137
Example applications utilizing the Data Plane Development Kit, such
138
as L2 and L3 forwarding.
139
%endif
140
141
%ifnarch %{ix86}
142
%package kmp
143
Summary: DPDK KNI kernel module (thunderx)
144
Group: System/Kernel
145
BuildRequires: %{kernel_module_package_buildreqs}
146
Conflicts: otherproviders(dpdk-any-kmp)
147
%suse_kernel_module_package -p %{_sourcedir}/preamble pae 64kb
148
149
%description kmp
150
The DPDK Kernel NIC Interface (KNI) allows userspace applications access to the Linux* control plane.
151
%endif
152
153
%define sdkdir %{_datadir}/dpdk
154
%define docdir %{_docdir}/dpdk
155
%define incdir %{_includedir}/dpdk
156
%define pmddir %{_libdir}/dpdk-pmds
157
158
%prep
159
# can't use %{name} because of dpdk-thunderx
160
%setup -q -n dpdk-stable-%{version}
161
%patch1 -p1 -z .enic
162
163
# This fixes CROSS compilation (broken) in the mk file for ThunderX
164
sed -i '/^CROSS /s/^/#/' mk/machine/thunderx/rte.vars.mk
165
166
%build
167
# set up a method for modifying the resulting .config file
168
function setconf() {
169
if grep -q ^$1= $3/.config; then
170
sed -i "s:^$1=.*$:$1=$2:g" $3/.config
171
else
172
echo $1=$2 >> $3/.config
173
fi
174
}
175
176
function setdefaultconf()
177
{
178
setconf CONFIG_RTE_MACHINE '"%{machine2}"' $1
179
# Disable experimental features
180
setconf CONFIG_RTE_NEXT_ABI n $1
181
182
# SONAME equals to DPDK release version
183
setconf CONFIG_RTE_MAJOR_ABI %{version} $1
184
185
# Enable automatic driver loading from this path
186
setconf CONFIG_RTE_EAL_PMD_PATH '"%{pmddir}"' $1
187
188
setconf CONFIG_RTE_LIBRTE_BNX2X_PMD y $1
189
setconf CONFIG_RTE_LIBRTE_BNX2X_MF_SUPPORT y $1
190
setconf CONFIG_RTE_LIBRTE_PMD_PCAP y $1
191
setconf CONFIG_RTE_LIBRTE_VHOST_NUMA y $1
192
setconf CONFIG_RTE_LIBRTE_MLX5_PMD y $1
193
setconf CONFIG_RTE_LIBRTE_MLX4_PMD y $1
194
195
setconf CONFIG_RTE_EAL_IGB_UIO n $1
196
setconf CONFIG_RTE_KNI_KMOD n $1
197
198
%if %{with shared}
199
setconf CONFIG_RTE_BUILD_SHARED_LIB y $1
200
%endif
201
202
%ifarch aarch64 ppc64le
203
setconf CONFIG_RTE_LIBRTE_DISTRIBUTOR n $1
204
%endif
205
%ifarch ppc64le
206
setconf CONFIG_RTE_LIBRTE_PMD_RING n $1
207
setconf CONFIG_RTE_LIBRTE_IXGBE_PMD n $1
208
setconf CONFIG_RTE_LIBRTE_POWER n $1
209
%endif
210
}
211
# In case dpdk-devel is installed, we should ignore its hints about the SDK directories
212
unset RTE_SDK RTE_INCLUDE RTE_TARGET
213
214
# For the release, '-Wno-error=array-bounds' is done to prevent a spurious error
215
# generated by gcc 5.X against the 2.1 branch
216
export EXTRA_CFLAGS="%{optflags} -Wformat -fPIC -Wno-error=array-bounds"
217
218
# DPDK defaults to using builder-specific compiler flags. However,
219
# the config has been changed by specifying CONFIG_RTE_MACHINE=default
220
# in order to build for a more generic host. NOTE: It is possible that
221
# the compiler flags used still won't work for all Fedora-supported
222
# machines, but runtime checks in DPDK will catch those situations.
223
224
make V=1 O=%{target} T=%{target} %{?_smp_mflags} config
225
setdefaultconf %{target}
226
227
%ifnarch %{ix86}
228
export EXTRA_CFLAGS='-DVERSION=\"%{version}\"'
229
for flavor in %{flavors_to_build}; do
230
export RTE_KERNELDIR=%{_prefix}/src/linux-obj/%{_target_cpu}/$flavor
231
make V=1 O=%{target}-$flavor T=%{target} %{?_smp_mflags} config
232
setdefaultconf %{target}-$flavor
233
%ifnarch %{ix86}
234
setconf CONFIG_RTE_EAL_IGB_UIO y %{target}-$flavor
235
setconf CONFIG_RTE_KNI_KMOD y %{target}-$flavor
236
%endif
237
cd %{target}-$flavor
238
make V=1 %{?_smp_mflags}
239
cd -
240
done
241
%endif
242
243
make V=1 O=%{target} %{?_smp_mflags}
244
make V=1 O=%{target} %{?_smp_mflags} doc-api-html
245
246
%if %{with examples}
247
make V=1 O=%{target}/examples T=%{target} %{?_smp_mflags} examples
248
%endif
249
250
%install
251
%ifnarch %{ix86}
252
# export needed for kmp package
253
export EXTRA_CFLAGS='-DVERSION=\"%{version}\"'
254
export INSTALL_MOD_PATH=%{buildroot}
255
export INSTALL_MOD_DIR=updates
256
export BRP_PESIGN_FILES="*.ko"
257
258
for flavor in %{flavors_to_build}; do
259
cd %{target}-$flavor
260
export RTE_KERNELDIR=%{_prefix}/src/linux-obj/%{_target_cpu}/$flavor
261
dir=/usr/src/linux-obj/%{_target_cpu}/$flavor
262
krel=$(make -s -C "$dir" kernelrelease)
263
mkdir -p %{buildroot}/lib/modules/$krel/extra/dpdk/
264
#make install expects same kernel for build and target, lets copy it manually
265
install -m644 ../%{target}-$flavor/kmod/*.ko %{buildroot}/lib/modules/$krel/extra/dpdk/
266
cd -
267
done
268
%endif
269
# In case dpdk-devel is installed
270
unset RTE_SDK RTE_INCLUDE RTE_TARGET
271
272
%make_install O=%{target} prefix=%{_usr} libdir=%{_libdir}
273
274
%if ! %{with tools}
275
rm -rf %{buildroot}%{sdkdir}/usertools/
276
rm -rf %{buildroot}%{_sbindir}/dpdk_nic_bind
277
%endif
278
rm -f %{buildroot}%{sdkdir}/usertools/setup.sh
279
#TODO pip elftools has issues to fix
280
rm -rf %{buildroot}%{_bindir}/dpdk-pmdinfo
281
282
%if %{with examples}
283
find %{target}/examples/ -name "*.map" | xargs rm -f
284
for f in %{target}/examples/*/%{target}/app/*; do
285
bn=`basename ${f}`
286
cp -p ${f} %{buildroot}%{_bindir}/dpdk_example_${bn}
287
done
288
%endif
289
290
# Create a driver directory with symlinks to all pmds
291
mkdir -p %{buildroot}/%{pmddir}
292
for f in %{buildroot}/%{_libdir}/*_pmd_*.so.*; do
293
bn=$(basename ${f})
294
ln -s ../${bn} %{buildroot}%{pmddir}/${bn}
295
done
296
#mempool is a driver now from 16.07
297
mkdir -p %{buildroot}/%{pmddir}
298
for f in %{buildroot}/%{_libdir}/*_mempool_*.so.*; do
299
bn=$(basename ${f})
300
ln -s ../${bn} %{buildroot}%{pmddir}/${bn}
301
done
302
303
# Setup RTE_SDK environment as expected by apps etc
304
mkdir -p %{buildroot}/%{_sysconfdir}/profile.d
305
cat << EOF > %{buildroot}/%{_sysconfdir}/profile.d/dpdk-sdk-%{_arch}.sh
306
if [ -z "\${RTE_SDK}" ]; then
307
export RTE_SDK="%{sdkdir}"
308
export RTE_TARGET="%{target}"
309
export RTE_INCLUDE="%{incdir}"
310
fi
311
EOF
312
313
cat << EOF > %{buildroot}/%{_sysconfdir}/profile.d/dpdk-sdk-%{_arch}.csh
314
if ( ! \$RTE_SDK ) then
315
setenv RTE_SDK "%{sdkdir}"
316
setenv RTE_TARGET "%{target}"
317
setenv RTE_INCLUDE "%{incdir}"
318
endif
319
EOF
320
321
# Fixup target machine mismatch
322
sed -i -e 's:-%{machine}-:-%{machine2}-:g' %{buildroot}/%{_sysconfdir}/profile.d/dpdk-sdk*
323
324
#doc
325
mkdir %{buildroot}%{_docdir}/
326
mv %{buildroot}%{_datadir}/doc/dpdk %{buildroot}%{_docdir}/
327
328
ln -s %{_bindir}/dpdk-procinfo %{buildroot}%{_bindir}/dpdk_proc_info
329
ln -s %{_sbindir}/dpdk-devbind %{buildroot}%{_sbindir}/dpdk_nic_bind
330
331
# Remove duplicates
332
%fdupes %{buildroot}/%{_prefix}
333
334
%post devel -p /sbin/ldconfig
335
%postun devel -p /sbin/ldconfig
336
%post -n %{lname} -p /sbin/ldconfig
337
%postun -n %{lname} -p /sbin/ldconfig
338
339
%files
340
%defattr(-,root,root)
341
# BSD
342
%{_bindir}/testpmd
343
%{_bindir}/dpdk-procinfo
344
%{_bindir}/dpdk_proc_info
345
%{_bindir}/dpdk-pdump
346
347
%files -n %{lname}
348
%defattr(-,root,root)
349
%if %{with shared}
350
%dir %{_libdir}/dpdk-pmds
351
352
%{_libdir}/*.so.*
353
%{pmddir}/
354
%endif
355
356
%files doc
357
%defattr(-,root,root)
358
#BSD
359
%docdir
360
%doc LICENSE.GPL LICENSE.LGPL
361
362
%files devel
363
%defattr(-,root,root)
364
#BSD
365
%{incdir}/
366
%{sdkdir}
367
%if %{with tools}
368
%exclude %{sdkdir}/usertools/
369
%endif
370
%if %{with examples}
371
%exclude %{sdkdir}/examples/
372
%endif
373
%{_sysconfdir}/profile.d/dpdk-sdk-*.*
374
%if ! %{with shared}
375
%{_libdir}/*.a
376
%else
377
%{_libdir}/*.so
378
%endif
379
380
%if %{with tools}
381
%files tools
382
%defattr(-,root,root)
383
%{sdkdir}/usertools/
384
%{_sbindir}/dpdk-devbind
385
%{_sbindir}/dpdk_nic_bind
386
%{_bindir}/dpdk-test-eventdev
387
%{_bindir}/dpdk-test-crypto-perf
388
%endif
389
390
%if %{with examples}
391
%files examples
392
%defattr(-,root,root)
393
%{_bindir}/dpdk_example_*
394
%doc %{sdkdir}/examples
395
%endif
396
397
%changelog
398