File perl-Tie-Cycle.spec of Package perl-Tie-Cycle (Revision 1650c70287dbd7d8588b7f86d5e24c05)
Currently displaying revision 1650c70287dbd7d8588b7f86d5e24c05 , Show latest
110
1
#
2
# spec file for package perl-Tie-Cycle
3
#
4
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
Name: perl-Tie-Cycle
20
Version: 1.225
21
Release: 1.24
22
%define cpan_name Tie-Cycle
23
Summary: Cycle through a list of values via a scalar
24
License: Artistic-2.0
25
Group: Development/Libraries/Perl
26
Url: http://search.cpan.org/dist/Tie-Cycle/
27
Source0: https://cpan.metacpan.org/authors/id/B/BD/BDFOY/%{cpan_name}-%{version}.tar.gz
28
Source1: cpanspec.yml
29
BuildArch: noarch
30
BuildRoot: %{_tmppath}/%{name}-%{version}-build
31
BuildRequires: perl
32
BuildRequires: perl-macros
33
BuildRequires: perl(Test::More) >= 0.95
34
%{perl_requires}
35
36
%description
37
You use 'Tie::Cycle' to go through a list over and over again. Once you get
38
to the end of the list, you go back to the beginning. You don't have to
39
worry about any of this since the magic of tie does that for you.
40
41
The tie takes an array reference as its third argument. The tie should
42
succeed unless the argument is not an array reference. Previous versions
43
required you to use an array that had more than one element (what's the
44
pointing of looping otherwise?), but I've removed that restriction since
45
the number of elements you want to use may change depending on the
46
situation.
47
48
During the tie, this module makes a shallow copy of the array reference. If
49
the array reference contains references, and those references are changed
50
after the tie, the elements of the cycle will change as well. See the
51
included _test.pl_ script for an example of this effect.
52
53
%prep
54
%setup -q -n %{cpan_name}-%{version}
55
56
%build
57
%{__perl} Makefile.PL INSTALLDIRS=vendor
58
%{__make} %{?_smp_mflags}
59
60
%check
61
%{__make} test
62
63
%install
64
%perl_make_install
65
%perl_process_packlist
66
%perl_gen_filelist
67
68
%files -f %{name}.files
69
%defattr(-,root,root,755)
70
%doc Changes CONTRIBUTING.md examples
71
%license LICENSE
72
73
%changelog
74
* Mon Jul 10 2017 coolo@suse.com
75
- updated to 1.225
76
see /usr/share/doc/packages/perl-Tie-Cycle/Changes
77
1.225 2017-07-09T17:49:10Z
78
* Bump the version to reindex (See https://github.com/andk/pause/issues/248 )
79
* Wed Apr 19 2017 coolo@suse.com
80
- updated to 1.224
81
see /usr/share/doc/packages/perl-Tie-Cycle/Changes
82
1.224 2017-04-18T11:41:22Z
83
* Fix up various dist things and clarify that this is under
84
the Artistic License 2.0.
85
* Tue Feb 14 2017 coolo@suse.com
86
- updated to 1.222
87
see /usr/share/doc/packages/perl-Tie-Cycle/Changes
88
1.222 2017-01-20T11:30:37Z
89
* The module seems to have disappeared from CPAN, so I'm
90
re-uploading.
91
* Sun Feb 7 2016 coolo@suse.com
92
- updated to 1.221
93
see /usr/share/doc/packages/perl-Tie-Cycle/Changes
94
* Tue Apr 14 2015 coolo@suse.com
95
- updated to 1.21
96
see /usr/share/doc/packages/perl-Tie-Cycle/Changes
97
1.21 - Fri Oct 3 22:08:25 2014
98
* Update Makefile for better META data
99
1.19_01 - Mon Sep 2 10:51:42 2013
100
* Take out // (5.10 feature I used without thought) to restore
101
5.8 compatibility.
102
* Fri Oct 4 2013 coolo@suse.com
103
- updated to 1.19
104
* Update for modern usage, better code
105
* I use this as an example in Mastering Perl, so I shouldn't
106
leave embarrassing practices in the code. :)
107
* Fri Jun 28 2013 coolo@suse.com
108
- initial package 1.17
109
* created by cpanspec 1.78.06
110