File netty-tcnative.spec of Package netty-tcnative (Revision 9f2f7e04daca205779e04d69d9e4868c)
Currently displaying revision 9f2f7e04daca205779e04d69d9e4868c , Show latest
95
1
#
2
# spec file for package netty-tcnative
3
#
4
# Copyright (c) 2023 SUSE LLC
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
%global namedreltag .Final
20
%global namedversion %{version}%{?namedreltag}
21
Name: netty-tcnative
22
Version: 2.0.59
23
Release: 0
24
Summary: Fork of Tomcat Native with improved OpenSSL and mavenized build
25
License: Apache-2.0
26
URL: https://github.com/netty/netty/wiki/Forked-Tomcat-Native
27
Source0: https://github.com/netty/netty-tcnative/archive/%{name}-parent-%{namedversion}.tar.gz
28
Source1: fixLibNames.patch.in
29
Source2: https://repo1.maven.org/maven2/io/netty/netty-jni-util/0.0.3.Final/netty-jni-util-0.0.3.Final-sources.jar
30
BuildRequires: fdupes
31
BuildRequires: gcc
32
BuildRequires: java-devel >= 1.8
33
BuildRequires: libtcnative-1-0
34
BuildRequires: maven-local
35
BuildRequires: unzip
36
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
37
BuildRequires: mvn(org.sonatype.oss:oss-parent:pom:)
38
Requires: libtcnative-1-0
39
40
%description
41
netty-tcnative is a fork of Tomcat Native. It includes a set of changes
42
contributed by Twitter, Inc, such as:
43
* Simplified distribution and linkage of native library
44
* Complete mavenization of the project
45
* Improved OpenSSL support
46
To minimize the maintenance burden, we create a dedicated branch for each stable
47
upstream release and apply our own changes on top of it, while keeping the
48
number of maintained branches to minimum
49
50
%package javadoc
51
Summary: API documentation for %{name}
52
BuildArch: noarch
53
54
%description javadoc
55
%{summary}.
56
57
%prep
58
%setup -q -n %{name}-%{name}-parent-%{namedversion}
59
patch=`mktemp`
60
sed "s;@PATH@;%{_libdir};g" < %{SOURCE1} > $patch
61
patch -p1 < $patch
62
63
# Build only the openssl-dynamic module
64
%pom_disable_module openssl-static
65
%pom_disable_module boringssl-static
66
%pom_disable_module libressl-static
67
%pom_disable_module openssl-dynamic
68
69
%pom_remove_plugin :japicmp-maven-plugin .
70
%pom_remove_plugin :maven-enforcer-plugin .
71
%pom_remove_plugin :maven-antrun-plugin
72
%pom_xpath_remove pom:project/pom:build/pom:extensions
73
74
%pom_remove_dep io.netty:netty-jni-util
75
%pom_remove_plugin :maven-dependency-plugin
76
mkdir -p target/netty-jni-util
77
unzip %{SOURCE2} -d target/netty-jni-util
78
79
%build
80
%{mvn_build} -f -- \
81
%if %{?pkg_vcmp:%pkg_vcmp java-devel >= 9}%{!?pkg_vcmp:0}
82
-Dmaven.compiler.release=8 \
83
%endif
84
-Dsource=8
85
86
%install
87
%mvn_install
88
%fdupes -s %{buildroot}%{_javadocdir}
89
90
%files -f .mfiles
91
92
%files javadoc -f .mfiles-javadoc
93
94
%changelog
95