File invm-i18n.spec of Package invm-i18n (Revision 6b0bf9596ce0a52bca0dd2b72fcbc022)
Currently displaying revision 6b0bf9596ce0a52bca0dd2b72fcbc022 , Show latest
xxxxxxxxxx
1
#
2
# spec file for package intelnvm-i18n
3
#
4
# Copyright (c) 2016 Intel Corporation
5
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
# Please submit bugfixes or comments via http://bugs.opensuse.org/
17
#
18
19
# allow building with SLE12-compatible package-names
20
%bcond_with short-invm-dnames
21
22
Name: invm-i18n
23
Version: 1.0.0.1020
24
Release: 2.17
25
Summary: The Intel Internationalization library
26
License: BSD-3-Clause and BSD-2-Clause
27
Group: Development/Libraries/C and C++
28
URL: https://01.org/intel-nvm-i18n-library
29
Source: https://github.com/01org/libinvm-i18n/archive/v%{version}.tar.gz
30
ExclusiveArch: x86_64
31
BuildRequires: distribution-release
32
33
%define api_release 1
34
%define lname lib%{name}%{api_release}
35
%define srcname lib%{name}-%{version}
36
%if %{with short-invm-dnames}
37
%define dname %{name}-devel
38
%define altdname lib%{name}-devel
39
%else
40
%define dname lib%{name}-devel
41
%define altdname %{name}-devel
42
%endif
43
44
%description
45
libinvm-i18n is a framework library for Internationalization, supporting a
46
subset of Internationalization (I18n) functionality.
47
48
%package -n %{lname}
49
Summary: Library for Intel I18N framework
50
Group: System/Libraries
51
52
%description -n %{lname}
53
libinvm-i18n is a framework library for Internationalization, supporting a
54
subset of Internationalization (I18n) functionality.
55
This is a required library for using libinvm-cli library.
56
57
%package -n %{dname}
58
Summary: Development files for %{name}
59
Group: Development/Libraries/C and C++
60
Requires: %{lname} = %{version}-%{release}
61
Provides: %{altdname} = %{version}-%{release}
62
Obsoletes: %{altdname} < %{version}-%{release}
63
64
%description -n %{dname}
65
The %{name}-devel package contains header files for
66
developing applications that use %{name}.
67
68
%prep
69
%setup -q -n %{srcname}
70
71
%build
72
make BUILDNUM=%{version} RELEASE=1 \
73
CFLAGS_EXTERNAL="%{?optflags}" %{?_smp_mflags}
74
75
%install
76
make BUILDNUM=%{version} RELEASE=1 \
77
RPM_ROOT=%{buildroot} LIB_DIR=%{_libdir} INCLUDE_DIR=%{_includedir} \
78
install
79
80
%post -n %{lname} -p /sbin/ldconfig
81
%postun -n %{lname} -p /sbin/ldconfig
82
83
%files -n %{lname}
84
%defattr(-,root,root)
85
%{_libdir}/libinvm-i18n.so.*
86
%doc licenses/intel_bsd
87
88
%files -n %{dname}
89
%defattr(-,root,root)
90
%{_libdir}/libinvm-i18n.so
91
%dir %{_includedir}/libinvm-i18n
92
%{_includedir}/libinvm-i18n/*.h
93
%doc licenses/intel_bsd
94
%doc licenses/netbsd
95
96
%changelog
97
* Sat Aug 12 2017 jengelh@inai.de
98
- RPM group fix.
99
* Fri Aug 4 2017 rw@suse.com
100
- Harmonize spec file.
101
* Wed Mar 1 2017 rw@suse.com
102
- Minor version update to 1.0.0.1020. (FATE#321998, FATE#321999)
103
- Drop create-header-dir.patch.
104
* Mon Jul 4 2016 rw@suse.com
105
- Update naming for Intel NVM utils. (bsc#987543)
106
- Minor version update to 1.0.0.1015.
107
- Drop use-gcc-not-g++-for-linking.patch.
108
* Fri Apr 15 2016 jthumshirn@suse.com
109
- Initial packaging for SUSE (FATE#319636, FATE#319651)
110