File neon.spec of Package neon
132
1
#
2
# spec file for package neon
3
#
4
# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
Name: neon
20
Version: 0.30.2
21
Release: 0
22
Summary: An HTTP and WebDAV Client Library
23
License: GPL-2.0-or-later
24
Group: Development/Libraries/Other
25
Url: http://www.webdav.org/neon
26
Source0: http://www.webdav.org/neon/neon-%{version}.tar.gz
27
Source1: http://www.webdav.org/neon/neon-%{version}.tar.gz.asc
28
Source2: %{name}.keyring
29
Source3: baselibs.conf
30
Source10: replace_manpage_with_links.sh
31
# PATCH-MISSING-TAG -- See http://wiki.opensuse.org/Packaging/Patches
32
Patch0: %{name}-0.28.4-bloat.patch
33
Patch1: fix_timeout_tests_for_ppc64le.patch
34
Patch2: neon-0.30.2_ssl-fix_timeout_retvals.patch
35
# backport from upstream
36
Patch3: neon-0.30.2-nulcert.patch
37
Patch4: neon-test-sha256.patch
38
Patch5: neon-disable-tests-prebuilt-certs.patch
39
Patch6: neon-openssl3-truncation.patch
40
Patch7: neon-openssl3-socket-shutdown.patch
41
BuildRequires: krb5-devel
42
BuildRequires: libexpat-devel
43
BuildRequires: pkgconfig(openssl)
44
BuildRequires: libproxy-devel
45
BuildRequires: libtool
46
BuildRequires: openssl
47
BuildRequires: pkgconfig
48
BuildRequires: zlib-devel
49
50
%description
51
neon is an HTTP and WebDAV client library with a C interface.
52
53
%package -n libneon27
54
Summary: An HTTP and WebDAV Client Library
55
# Drop the main package. It avoids the lib from being installed in different versions
56
# and generally only contained coders doc anyhow.
57
Group: Development/Libraries/Other
58
Provides: neon = %{version}
59
Obsoletes: neon < %{version}
60
#
61
62
%description -n libneon27
63
neon is an HTTP and WebDAV client library with a C interface.
64
65
%package -n libneon-devel
66
Summary: An HTTP and WebDAV Client Library
67
Group: Development/Libraries/Other
68
Requires: glibc-devel
69
Requires: libneon27 = %{version}
70
# renamed after openSUSE 10.3
71
Provides: neon-devel = %{version}
72
Obsoletes: neon-devel < %{version}
73
74
%description -n libneon-devel
75
neon is an HTTP and WebDAV client library with a C interface.
76
77
%prep
78
%setup -q
79
%patch0
80
%ifarch ppc64le ppc64
81
%patch1
82
%endif
83
if pkg-config --atleast-version=1.1.1 openssl; then
84
%patch2 -p1
85
fi
86
%patch3 -p1
87
%patch4 -p1
88
%patch5 -p1
89
%patch6 -p1
90
%patch7 -p1
91
92
%build
93
rm -f aclocal.m4 ltmain.sh
94
sh autogen.sh
95
%configure \
96
--with-ssl \
97
--enable-threadsafe-ssl=posix \
98
--with-libproxy \
99
--with-expat \
100
--disable-nls \
101
--enable-shared \
102
--disable-static \
103
--enable-warnings
104
make %{?_smp_mflags}
105
106
%install
107
make DESTDIR=%{buildroot} docdir=%{_defaultdocdir}/%{name} install install-man install-html %{?_smp_mflags}
108
find %{buildroot} -type f -name "*.la" -delete -print
109
find %{buildroot}%{_mandir} -type f -exec bash %{S:10} {} \;
110
111
%check
112
make %{?_smp_mflags} check
113
114
%post -n libneon27 -p /sbin/ldconfig
115
%postun -n libneon27 -p /sbin/ldconfig
116
117
%files -n libneon27
118
%doc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
119
%{_libdir}/*.so.27*
120
%license src/COPYING.LIB
121
122
%files -n libneon-devel
123
%doc %{_defaultdocdir}/%{name}
124
%{_bindir}/neon-config
125
%dir %{_includedir}/neon
126
%{_includedir}/neon/*.h
127
%{_mandir}/*/*
128
%{_libdir}/*.so
129
%{_libdir}/pkgconfig/neon.pc
130
131
%changelog
132