File folks.spec of Package folks
250
1
#
2
# spec file for package folks
3
#
4
# Copyright (c) 2023 SUSE LLC
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
%global __requires_exclude libfolks|libfolks-dummy|libfolks-eds|libfolks-telepathy
19
20
%define soversion 26
21
%define module_version 26
22
%define with_telepathy 1
23
%define with_zeitgeist 0
24
25
Name: folks
26
Version: 0.15.6
27
Release: 0
28
Summary: Library to create metacontacts from multiple sources
29
License: LGPL-2.1-or-later
30
Group: Development/Libraries/C and C++
31
URL: http://telepathy.freedesktop.org/wiki/Folks
32
Source: https://download.gnome.org/sources/folks/0.15/%{name}-%{version}.tar.xz
33
34
BuildRequires: gettext
35
BuildRequires: gobject-introspection-devel
36
BuildRequires: meson >= 0.49
37
BuildRequires: pkgconfig
38
BuildRequires: python3-dbusmock
39
BuildRequires: readline-devel
40
BuildRequires: vala >= 0.22.0.28
41
BuildRequires: pkgconfig(dbus-glib-1)
42
BuildRequires: pkgconfig(gee-0.8) >= 0.8.6
43
BuildRequires: pkgconfig(gobject-2.0) >= 2.44.0
44
BuildRequires: pkgconfig(libebook-1.2) >= 3.38.0
45
BuildRequires: pkgconfig(libebook-contacts-1.2) >= 3.38.0
46
BuildRequires: pkgconfig(libedataserver-1.2) >= 3.38.0
47
BuildRequires: pkgconfig(libxml-2.0)
48
%if %{with_telepathy}
49
BuildRequires: pkgconfig(telepathy-glib) >= 0.19.9
50
%endif
51
%if %{with_zeitgeist}
52
BuildRequires: pkgconfig(zeitgeist-2.0) >= 0.9.14
53
%endif
54
Requires: python3-dbusmock
55
56
%description
57
libfolks is a library that aggregates people from multiple sources (e.g.
58
Telepathy connection managers) to create metacontacts.
59
60
%package -n libfolks%{soversion}
61
Summary: Library to create metacontacts from multiple sources
62
# To make lang package installable
63
# We assume that future -data packages remain backwards compatible
64
Group: System/Libraries
65
Requires: folks-data >= %{version}
66
Provides: %{name} = %{version}
67
68
%description -n libfolks%{soversion}
69
libfolks is a library that aggregates people from multiple sources (e.g.
70
Telepathy connection managers) to create metacontacts.
71
72
%package data
73
Summary: Data files for libfolks, a library to create metacontacts from many sources
74
Group: System/Libraries
75
Obsoletes: libfolks-data < %{version}
76
Provides: libfolks-data = %{version}
77
78
%description data
79
libfolks is a library that aggregates people from multiple sources (e.g.
80
Telepathy connection managers) to create metacontacts.
81
82
This package provides mandatory data files for the library to work.
83
84
%package -n typelib-1_0-Folks-0_7
85
Summary: Introspection bindings for libfolks
86
Group: System/Libraries
87
88
%description -n typelib-1_0-Folks-0_7
89
libfolks is a library that aggregates people from multiple sources (e.g.
90
Telepathy connection managers) to create metacontacts.
91
92
This package provides the GObject Introspection bindings for libfolks.
93
94
%package -n typelib-1_0-FolksEds-0_7
95
Summary: Introspection bindings for libfolks-eds
96
Group: System/Libraries
97
98
%description -n typelib-1_0-FolksEds-0_7
99
libfolks is a library that aggregates people from multiple sources (e.g.
100
Telepathy connection managers) to create metacontacts.
101
102
This package provides the GObject Introspection bindings for libfolks.
103
104
%package -n typelib-1_0-FolksTelepathy-0_7
105
Summary: Introspection bindings for libfolks-telepathy
106
Group: System/Libraries
107
108
%description -n typelib-1_0-FolksTelepathy-0_7
109
libfolks is a library that aggregates people from multiple sources (e.g.
110
Telepathy connection managers) to create metacontacts.
111
112
This package provides the GObject Introspection bindings for libfolks.
113
114
%package -n libfolks-eds%{soversion}
115
Summary: Evolution Data Server backend for libfolks
116
Group: System/Libraries
117
Supplements: (libfolks%{soversion} and evolution-data-server)
118
119
%description -n libfolks-eds%{soversion}
120
libfolks is a library that aggregates people from multiple sources (e.g.
121
Telepathy connection managers) to create metacontacts.
122
123
%package -n libfolks-telepathy%{soversion}
124
Summary: Telepathy backend for libfolks
125
Group: System/Libraries
126
127
%description -n libfolks-telepathy%{soversion}
128
libfolks is a library that aggregates people from multiple sources (e.g.
129
Telepathy connection managers) to create metacontacts.
130
131
%package tools
132
Summary: Additional utilities related to libfolks
133
# the folks-import tool is useful for old pidgin users
134
Group: Development/Libraries/GNOME
135
Supplements: (libfolks1 and pidgin)
136
137
%description tools
138
libfolks is a library that aggregates people from multiple sources (e.g.
139
Telepathy connection managers) to create metacontacts.
140
141
This package provides tools based on libfolks, like an importer for Pidgin
142
metacontacts.
143
144
%package devel
145
Summary: Development files for libfolks
146
Group: Development/Libraries/GNOME
147
Requires: libfolks%{soversion} = %{version}
148
Requires: libfolks-eds%{soversion} = %{version}
149
Requires: libfolks-telepathy%{soversion} = %{version}
150
Requires: typelib-1_0-Folks-0_7 = %{version}
151
Requires: typelib-1_0-FolksEds-0_7 = %{version}
152
Requires: typelib-1_0-FolksTelepathy-0_7 = %{version}
153
154
%description devel
155
libfolks is a library that aggregates people from multiple sources (e.g.
156
Telepathy connection managers) to create metacontacts.
157
158
This package provides the development files.
159
160
%lang_package
161
162
%prep
163
%autosetup -p1
164
165
%build
166
%define _lto_cflags %{nil}
167
%meson \
168
%if %{with_zeitgeist}
169
-Dzeitgeist=true \
170
%endif
171
%if ! %{with_telepathy}
172
-Dtelepathy_backend=false \
173
%endif
174
%{nil}
175
%meson_build
176
177
%install
178
%meson_install
179
find %{buildroot} -type f -name "*.la" -delete -print
180
# We don't need the gconf -> gsettings convesion tool anymore
181
# it was not installed in the previous versions and did not
182
# cause bug reports.
183
rm %{buildroot}/usr/share/GConf/gsettings/folks.convert
184
%find_lang folks %{?no_lang_C}
185
186
%ldconfig_scriptlets -n libfolks%{soversion}
187
%ldconfig_scriptlets -n libfolks-eds%{soversion}
188
%ldconfig_scriptlets -n libfolks-telepathy%{soversion}
189
190
%files -n libfolks%{soversion}
191
%license COPYING
192
%doc AUTHORS NEWS README.md
193
%{_libdir}/libfolks.so.%{soversion}*
194
%{_libdir}/libfolks-dummy.so.%{soversion}*
195
%dir %{_libdir}/folks
196
%dir %{_libdir}/folks/%{module_version}
197
%dir %{_libdir}/folks/%{module_version}/backends
198
%{_libdir}/folks/%{module_version}/backends/bluez/
199
%{_libdir}/folks/%{module_version}/backends/dummy/
200
%{_libdir}/folks/%{module_version}/backends/key-file/
201
%{_libdir}/folks/%{module_version}/backends/ofono/
202
203
%files data
204
%{_datadir}/glib-2.0/schemas/org.freedesktop.folks.gschema.xml
205
206
%files -n typelib-1_0-Folks-0_7
207
%{_libdir}/girepository-1.0/Folks-0.7.typelib
208
%{_libdir}/girepository-1.0/FolksDummy-0.7.typelib
209
210
%files -n typelib-1_0-FolksEds-0_7
211
%{_libdir}/girepository-1.0/FolksEds-0.7.typelib
212
213
%files -n libfolks-eds%{soversion}
214
%{_libdir}/libfolks-eds.so.%{soversion}*
215
%dir %{_libdir}/folks/%{module_version}/backends/eds
216
%{_libdir}/folks/%{module_version}/backends/eds/eds.so
217
218
%if %{with_telepathy}
219
%files -n typelib-1_0-FolksTelepathy-0_7
220
%{_libdir}/girepository-1.0/FolksTelepathy-0.7.typelib
221
222
%files -n libfolks-telepathy%{soversion}
223
%{_libdir}/libfolks-telepathy.so.%{soversion}*
224
%dir %{_libdir}/folks/%{module_version}/backends/telepathy
225
%{_libdir}/folks/%{module_version}/backends/telepathy/telepathy.so
226
%endif
227
228
%files tools
229
%{_bindir}/folks-import
230
%{_bindir}/folks-inspect
231
232
%files devel
233
%{_includedir}/folks/
234
%{_libdir}/*.so
235
%{_libdir}/pkgconfig/*.pc
236
%{_datadir}/gir-1.0/Folks-0.7.gir
237
%{_datadir}/gir-1.0/FolksDummy-0.7.gir
238
%{_datadir}/gir-1.0/FolksEds-0.7.gir
239
%if %{with_telepathy}
240
%{_datadir}/gir-1.0/FolksTelepathy-0.7.gir
241
%{_datadir}/vala/vapi/folks-telepathy.*
242
%endif
243
%{_datadir}/vala/vapi/folks.*
244
%{_datadir}/vala/vapi/folks-dummy.*
245
%{_datadir}/vala/vapi/folks-eds.*
246
247
%files lang -f %{name}.lang
248
249
%changelog
250