File time.spec of Package time (Revision cfff46207bc62165753d8bd5937df25a)
Currently displaying revision cfff46207bc62165753d8bd5937df25a , Show latest
137
1
#
2
# spec file for package time
3
#
4
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
Name: time
20
Version: 1.9
21
Release: 1.15
22
Summary: Run Programs And Summarize System Resource Usage
23
License: GPL-3.0+
24
Group: System/Base
25
Url: http://www.gnu.org/software/time/
26
Source: http://ftp.gnu.org/gnu/time/%{name}-%{version}.tar.gz
27
Source1: %{name}.rpmlintrc
28
Source2: http://ftp.gnu.org/gnu/time/%{name}-%{version}.tar.gz.sig
29
Source3: https://savannah.gnu.org/people/viewgpg.php?user_id=94790#/%{name}.keyring
30
Requires(post): %{install_info_prereq}
31
Requires(preun): %{install_info_prereq}
32
33
%description
34
The "time" command runs another program, then displays information
35
about the resources used by that program, collected by the system
36
while the program was running.
37
38
%prep
39
%setup -q
40
41
%build
42
%configure
43
make %{?_smp_mflags}
44
45
%install
46
%make_install
47
install -d %{buildroot}%{_mandir}/man1
48
49
%check
50
make %{?_smp_mflags} check
51
52
%post
53
%install_info --entry="* time: (time). summarizing used system resources" --info-dir="%{_infodir}" "%{_infodir}/time.info.gz"
54
55
%postun
56
%install_info_delete --info-dir="%{_infodir}" "%{_infodir}/time.info.gz"
57
58
%files
59
%license COPYING
60
%doc AUTHORS NEWS README
61
%{_bindir}/time
62
%{_infodir}/time.info*%{ext_info}
63
64
%changelog
65
* Mon Mar 12 2018 astieger@suse.com
66
- time 1.9:
67
* reports percent CPU usage for programs lasting less then 1s
68
* "time -p" no longers adds the "Command exited with non-zero
69
status" message (POSIX compliance)
70
- Use %%license (boo#1082318)
71
* Sat Nov 18 2017 astieger@suse.com
72
- time 1.8:
73
* license changed to GPL-3.0+
74
- incorporate functionality previously carried as patches:
75
* -q/--quiet option to suppresses abnormal program terminal
76
(non-exit codes or signals).
77
Drop time-debian-quiet.patch
78
Drop time-fedora-verbose.patch
79
* use the following exit codes (same as GNU coreutils' env):
80
125 = Wrong usage or internal error prior to exec attempt.
81
126 = Program located, but not usable.
82
127 = Could not find program to exec.
83
* exit with code '128 + Signal number' when the program
84
is terminated by a signal.
85
Drop time-debian-non-normal-exit.patch
86
* report MAX-RSS values correctly on modern systems
87
Drop time-fedora-ru_maxrss-is-in-kilobytes-on-Linux.patch
88
Drop time-fedora-Recompute-CPU-usage-at-microsecond-level.patch
89
* Use gnulib modules and build infrastructure.
90
* New tests infrastructure (make check).
91
- drop unneeded patches:
92
* time-debian-bug-address.patch
93
* time-alpha.patch
94
* time-debian-configure.patch
95
* time-debian-info-direntry.patch
96
* time-debian-info-nav.patch
97
* time-debian-rusage-portability.patch
98
* time-fsf-address.patch
99
- add upstream keyring and verify source signature
100
* Fri May 23 2014 sbrabec@suse.cz
101
- Add time.rpmlint suppressing the missing time man page warning.
102
* Tue May 20 2014 pgajdos@suse.com
103
- remove time.1 [bnc#878057]
104
* Thu Sep 5 2013 sbrabec@suse.cz
105
- Sync patches with Debian and Fedora:
106
* Add man page (time.1).
107
* Less nonverbose output (time-fedora-verbose.patch).
108
* Fix maximal RSS report
109
(time-fedora-ru_maxrss-is-in-kilobytes-on-Linux.patch,
110
bnc#836049, Redhat#702826).
111
* Switch to microsecond accuracy if miliseconds arithmetic rounds
112
to zero
113
(time-fedora-Recompute-CPU-usage-at-microsecond-level.patch,
114
Redhat#527276).
115
* When time exits in a non-normal way, return 128 plus the number
116
of the signal which caused time to stop or abort
117
(time-debian-non-normal-exit.patch).
118
* struct rusage and sys/resource.h portability fix
119
(time-debian-rusage-portability.patch, Debian#144819).
120
* Add -q,--quiet functionality
121
(time-debian-quiet.patch, Debian#56853).
122
* Update bug reporting address
123
(time-debian-bug-address.patch, Debian#542469).
124
* Modernize the configure.in file to current autoconf style
125
(time-debian-configure.patch).
126
* Add a directory entry to the info page
127
(time-debian-info-direntry.patch).
128
- Fix FSF address (time-fsf-address.patch).
129
- Update Summary.
130
- Rename time-1.7.diff to time-alpha.patch.
131
* Sun Jan 20 2013 jengelh@inai.de
132
- Split "time" off util-linux
133
* Tue Feb 21 2012 puzel@suse.com
134
- disabled make check for time (noop)
135
* Wed Oct 30 2002 ro@suse.de
136
- hack time to build on alpha
137