File lttng-modules.spec of Package lttng-modules
xxxxxxxxxx
1
#
2
# spec file for package lttng-modules
3
#
4
# Copyright (c) 2020 SUSE LLC
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
# needssslcertforbuild
19
20
%if ! 0%{?is_opensuse}
21
%ifarch x86_64
22
%define buildrt 1
23
%endif
24
%endif
25
26
Name: lttng-modules
27
Version: 2.13.7
28
Release: 0
29
Summary: Licensing information for package lttng-modules
30
License: GPL-2.0-only AND LGPL-2.1-only AND MIT
31
Group: System/Kernel
32
URL: https://lttng.org/
33
Source: https://lttng.org/files/lttng-modules/%{name}-%{version}.tar.bz2
34
Source1: https://lttng.org/files/lttng-modules/%{name}-%{version}.tar.bz2.asc
35
Source2: %{name}.keyring
36
Source3: %{name}-preamble
37
Source4: Module.supported
38
39
Patch1: block-remove-the-rq_disk_field_in_struct_request_v5.17.patch
40
Patch2: block-remove-genhd-h-v5.18.patch
41
Patch3: block-remove-GENHD_FL_SUPPRESS_PARTITION_INFO-v5.17.patch
42
Patch4: scsi-block-remove-REQ_OP_WRITE_SAME-support-v5.18.patch
43
Patch5: mm-compaction-cleanup-the-compaction-trace-events-v5.18.patch
44
Patch6: scsi-core-remove-scsi_request.h-v5.18.patch
45
Patch7: fix-jbd2-use-the-correct-print-format.patch
46
47
BuildRequires: kernel-devel
48
BuildRequires: kernel-source
49
BuildRequires: kernel-syms
50
BuildRequires: module-init-tools
51
%if 0%{?buildrt} == 1
52
BuildRequires: kernel-syms-rt
53
BuildRequires: kernel-source-rt
54
%endif
55
ExclusiveArch: x86_64
56
57
%description
58
This package provides licensing documentation for the lttng kmp packages.
59
60
%kernel_module_package -p %{name}-preamble -x ec2 xen xenpae vmi um
61
62
%prep
63
%autosetup -p1
64
65
set -- *
66
mkdir source obj
67
68
for i in "$@"; do
69
case $i in
70
LICENSE|LICENSES|ChangeLog) ;;
71
*) mv $i source ;;
72
esac
73
done
74
75
%build
76
export EXTRA_CFLAGS='-DVERSION=\"%{version}\"'
77
for flavor in %{flavors_to_build}; do
78
rm -rf obj/$flavor
79
cp -r source obj/$flavor
80
cp %{SOURCE4} obj/$flavor
81
%make_build -C %{kernel_source $flavor} modules \
82
M=$PWD/obj/$flavor CONFIG_LTTNG=m CONFIG_LTTNG_CLOCK_PLUGIN_TEST=m
83
done
84
85
%install
86
export INSTALL_MOD_PATH=%{buildroot}
87
export INSTALL_MOD_DIR=updates
88
export BRP_PESIGN_FILES="*.ko /lib/firmware"
89
for flavor in %{flavors_to_build}; do
90
make -C %{kernel_source $flavor} modules_install \
91
M=$PWD/obj/$flavor CONFIG_LTTNG=m CONFIG_LTTNG_CLOCK_PLUGIN_TEST=m
92
done
93
94
%files
95
%license LICENSE LICENSES/GPL-2.0 LICENSES/LGPL-2.1 LICENSES/MIT
96
%doc ChangeLog
97
98
%changelog
99