File perl-CPAN-Meta-Requirements.spec of Package perl-CPAN-Meta-Requirements (Revision 2bc5225583b30811c708ab7ec5307c7c)
Currently displaying revision 2bc5225583b30811c708ab7ec5307c7c , Show latest
163
1
#
2
# spec file for package perl-CPAN-Meta-Requirements
3
#
4
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
Name: perl-CPAN-Meta-Requirements
20
Version: 2.140000
21
Release: 1.24
22
%define cpan_version 2.140
23
Provides: perl(CPAN::Meta::Requirements) = 2.140000
24
%define cpan_name CPAN-Meta-Requirements
25
Summary: Set of Version Requirements for a Cpan Dist
26
License: Artistic-1.0 or GPL-1.0+
27
Group: Development/Libraries/Perl
28
Url: http://search.cpan.org/dist/CPAN-Meta-Requirements/
29
Source0: http://www.cpan.org/authors/id/D/DA/DAGOLDEN/%{cpan_name}-%{cpan_version}.tar.gz
30
Source1: cpanspec.yml
31
BuildArch: noarch
32
BuildRoot: %{_tmppath}/%{name}-%{version}-build
33
BuildRequires: perl
34
BuildRequires: perl-macros
35
BuildRequires: perl(Test::More) >= 0.88
36
BuildRequires: perl(version) >= 0.88
37
Requires: perl(version) >= 0.88
38
%{perl_requires}
39
40
%description
41
A CPAN::Meta::Requirements object models a set of version constraints like
42
those specified in the _META.yml_ or _META.json_ files in CPAN
43
distributions, and as defined by CPAN::Meta::Spec; It can be built up by
44
adding more and more constraints, and it will reduce them to the simplest
45
representation.
46
47
Logically impossible constraints will be identified immediately by thrown
48
exceptions.
49
50
%prep
51
%setup -q -n %{cpan_name}-%{cpan_version}
52
53
%build
54
%{__perl} Makefile.PL INSTALLDIRS=vendor
55
%{__make} %{?_smp_mflags}
56
57
%check
58
%{__make} test
59
60
%install
61
%perl_make_install
62
%perl_process_packlist
63
%perl_gen_filelist
64
65
%files -f %{name}.files
66
%defattr(-,root,root,755)
67
%doc Changes CONTRIBUTING.mkdn LICENSE README
68
69
%changelog
70
* Sun Dec 13 2015 coolo@suse.com
71
- updated to 2.140
72
see /usr/share/doc/packages/perl-CPAN-Meta-Requirements/Changes
73
2.140 2015-12-12 16:17:15-05:00 America/New_York
74
- no changes from 2.139
75
2.139 2015-12-11 12:42:44-05:00 America/New_York (TRIAL RELEASE)
76
- expanded dist.ini from author bundle to individual plugins
77
2.138 2015-07-13 22:32:37-04:00 America/New_York (TRIAL RELEASE)
78
- repackage with fixed tests
79
2.137 2015-07-09 09:53:32-04:00 America/New_York (TRIAL RELEASE)
80
- much better error messages, explaining what conflicted and how
81
2.136 2015-06-08 21:35:27-06:00 America/Denver (TRIAL RELEASE)
82
[FIXED]
83
- On Perls before 5.8.1, pad 1-part and 2-part literal v-strings
84
to avoid old version.pm bugs with v-strings less than 3 characters
85
- Protect internal _isa_version from non-refs that pass
86
- >isa('version')
87
2.135 2015-05-19 13:15:35-04:00 America/New_York (TRIAL RELEASE)
88
[TESTING]
89
- Skips impossible tests on Perls earlier than 5.8.0 (before
90
v-string magic).
91
2.134 2015-04-18 13:20:56+02:00 Europe/Berlin (TRIAL RELEASE)
92
[ADDED]
93
- Added method for getting structured requirements
94
* Thu Apr 16 2015 coolo@suse.com
95
- updated to 2.133
96
see /usr/share/doc/packages/perl-CPAN-Meta-Requirements/Changes
97
2.133 2015-02-22 06:35:34-05:00 America/New_York
98
[FIXED]
99
- In fixing preservation of "0.00", some Module => 0 optimizations were
100
lost; this restores those optimizations
101
2.132 2015-01-22 17:09:19-05:00 America/New_York
102
[FIXED]
103
- Precision of version requirement "0.00" is preserved when merging
104
requirements.
105
2.131 2014-12-23 15:04:19-05:00 America/New_York
106
[ENHANCEMENTS]
107
- Merging Module => 0 into requirements is now optimized
108
[PREREQS]
109
- Scalar::Utils removed as a prerequisite
110
2.130 2014-11-19 23:25:46-05:00 America/New_York
111
[ADDED]
112
- from_string_hash can take optional constructor arguments
113
[CHANGED]
114
- bad_version_hook callback gets module name as well as version string
115
- undefined/empty versions given to from_string_hash or
116
add_string_requirement now carp and are coerced to "0" instead of
117
being fatal. This is more consistent with how the other requirement
118
functions work.
119
2.129 2014-11-13 16:28:45-05:00 America/New_York
120
[FIXED]
121
- from_string_hash can now accept v-strings as hash values
122
2.128 2014-09-06 00:04:22-04:00 America/New_York
123
[FIXED]
124
- Throws an error at compile time if neither version nor
125
the ExtUtils::MakeMaker bootstrap are available
126
2.127 2014-09-04 22:17:44-04:00 America/New_York
127
[FIXED]
128
- Works around limitations in version::vpp detecting v-string magic
129
[PREREQS]
130
- Requires version.pm 0.88 in metadata, but code should work with any
131
version of version.pm
132
- Adds support for forthcoming ExtUtils::MakeMaker bootstrap version.pm
133
for Perls older than 5.10.0
134
2.126 2014-07-30 16:26:29-04:00 America/New_York
135
[FIXED]
136
- Fixed compatibility with version.pm 0.77
137
[DOCUMENTED]
138
- Minor documentation fixes
139
[CHANGED]
140
- Modernized distribution meta files
141
* Fri Dec 6 2013 coolo@suse.com
142
- readd the fake provides - removing them was wrong
143
* Tue Nov 26 2013 coolo@suse.com
144
- more fake provides
145
* Fri Oct 4 2013 coolo@suse.com
146
- updated to 2.125
147
[FIXED]
148
- updated Makefile.PL logic to support PERL_NO_HIGHLANDER
149
- Better fix than 2.123. On old perls, rather than install into
150
'core', we continue to install into the proper 'site' library,
151
but force UNINST=1 when necessary to remove stale copies
152
from ExtUtils::MakeMaker
153
- On Perls prior to v5.12, CPAN::Meta::Requirements will be installed
154
into the 'core' library path to avoid an older version bundled with
155
ExtUtils::MakeMaker and installed there taking precedence.
156
* Tue Jun 11 2013 coolo@suse.com
157
- rebuild for fixed perl macros
158
* Mon Jun 3 2013 coolo@suse.com
159
- add workaround for mismatch between rpm and perl version logic
160
* Thu May 31 2012 coolo@suse.com
161
- initial package 2.122
162
* created by cpanspec 1.78.06
163