File glade.spec of Package glade
166
1
#
2
# spec file for package glade
3
#
4
# Copyright (c) 2021 SUSE LLC
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
%define soname libgladeui-2-13
20
21
Name: glade
22
Version: 3.38.2
23
Release: 0
24
Summary: User Interface Builder for GTK+ 3
25
License: GPL-2.0-or-later
26
Group: Development/Tools/GUI Builders
27
URL: https://glade.gnome.org/
28
Source0: https://download.gnome.org/sources/glade/3.38/%{name}-%{version}.tar.xz
29
# PATCH-FIX-UPSTREAM 9db1fba1fa93905c9169c1e29049e4b2f6337c39.patch -- GladeProject: Segfault in gnome-builder when widget doesn't have a name
30
Patch0: https://gitlab.gnome.org/GNOME/glade/-/commit/9db1fba1fa93905c9169c1e29049e4b2f6337c39.patch
31
32
BuildRequires: fdupes
33
BuildRequires: gobject-introspection-devel
34
BuildRequires: gtk-doc
35
BuildRequires: intltool
36
BuildRequires: meson >= 0.49.0
37
BuildRequires: pkgconfig
38
BuildRequires: python3-devel
39
BuildRequires: yelp-tools
40
BuildRequires: pkgconfig(gjs-1.0)
41
BuildRequires: pkgconfig(glib-2.0) >= 2.64.0
42
BuildRequires: pkgconfig(gmodule-2.0)
43
BuildRequires: pkgconfig(gmodule-export-2.0)
44
BuildRequires: pkgconfig(gobject-2.0) >= 2.10.0
45
BuildRequires: pkgconfig(gtk+-3.0) >= 3.20.0
46
BuildRequires: pkgconfig(libxml-2.0) >= 2.4.0
47
BuildRequires: pkgconfig(pygobject-3.0) >= 3.8.0
48
BuildRequires: pkgconfig(webkit2gtk-4.0) >= 2.28.0
49
50
%description
51
Glade is a RAD tool to develop user interfaces for the Gtk+ 3 toolkit
52
and the GNOME desktop environment.
53
54
%package -n %{soname}
55
Summary: Core library of the GLADE User Interface Builder
56
Group: System/Libraries
57
58
%description -n %{soname}
59
Glade is a RAD tool to develop user interfaces for the Gtk+ 3 toolkit
60
and the GNOME desktop environment.
61
62
%package -n typelib-1_0-Gladeui-2_0
63
Summary: Introspection bindins for libgladeui
64
Group: System/Libraries
65
66
%description -n typelib-1_0-Gladeui-2_0
67
Glade is a RAD tool to develop user interfaces for the Gtk+ 3 toolkit
68
and the GNOME desktop environment.
69
70
This package provides the GObject Introspection bindings for the
71
libgladeui library.
72
73
%package -n libgladeui-2-devel
74
Summary: Development files for libgladeui
75
Group: Development/Libraries/C and C++
76
Requires: %{soname} = %{version}
77
Requires: typelib-1_0-Gladeui-2_0 = %{version}
78
# The gtk-doc documentation is not parallel installable (bnc#646997)
79
Conflicts: libgladeui-1-devel
80
81
%description -n libgladeui-2-devel
82
Glade is a RAD tool to develop user interfaces for the Gtk+ 3 toolkit
83
and the GNOME desktop environment.
84
85
This subpackage contains the header files for developing
86
applications that want to make use of libgladeui.
87
88
%package docs
89
Summary: Documentation for GLADE User Interface Builder
90
91
%description docs
92
Glade is a RAD tool to develop user interfaces for the Gtk+ 3 toolkit
93
and the GNOME desktop environment.
94
95
This package contains the documentation for Glade.
96
97
%lang_package
98
99
%prep
100
%autosetup -p1
101
102
%build
103
%meson \
104
-Dgtk_doc=true \
105
%{nil}
106
%meson_build
107
108
%install
109
%meson_install
110
%find_lang %{name} %{?no_lang_C}
111
%fdupes %{buildroot}%{_datadir}
112
113
%ldconfig_scriptlets -n %{soname}
114
115
%files
116
%license COPYING COPYING.GPL COPYING.LGPL
117
%doc NEWS
118
%doc %{_datadir}/help/C/%{name}/
119
%{_bindir}/glade
120
%{_bindir}/glade-previewer
121
%dir %{_datadir}/metainfo
122
%{_datadir}/metainfo/org.gnome.Glade.appdata.xml
123
%{_datadir}/applications/org.gnome.Glade.desktop
124
%{_datadir}/glade/
125
%{_datadir}/gettext/its/glade-catalog.its
126
%{_datadir}/gettext/its/glade-catalog.loc
127
%{_datadir}/icons/hicolor/*/apps/*.*
128
%{_libdir}/glade/modules/libgladegjs.so
129
%{_libdir}/glade/modules/libgladegtk.so
130
%{_libdir}/glade/modules/libgladepython.so
131
%{_libdir}/glade/modules/libgladewebkit2gtk.so
132
%{_mandir}/man1/glade-previewer.1%{?ext_man}
133
%{_mandir}/man1/glade.1%{?ext_man}
134
135
%files -n %{soname}
136
%{_libdir}/libgladeui*.so.*
137
# These directories are needed by third-party catalogs, and are explicitly
138
# referenced in the pkg-config file, so it makes sense to own them here
139
%dir %{_datadir}/glade
140
%dir %{_datadir}/glade/catalogs
141
%dir %{_datadir}/glade/pixmaps
142
%dir %{_datadir}/glade/pixmaps/hicolor
143
%dir %{_datadir}/glade/pixmaps/hicolor/*
144
%dir %{_datadir}/glade/pixmaps/hicolor/*/actions
145
%dir %{_libdir}/glade
146
%dir %{_libdir}/glade/modules
147
148
%files -n typelib-1_0-Gladeui-2_0
149
%{_libdir}/girepository-1.0/Gladeui-2.0.typelib
150
151
%files -n libgladeui-2-devel
152
%doc AUTHORS TODO
153
%{_includedir}/libgladeui-2.0/
154
%{_libdir}/pkgconfig/gladeui-2.0.pc
155
%{_libdir}/libgladeui*.so
156
%{_datadir}/gir-1.0/*.gir
157
158
%files lang -f %{name}.lang
159
160
%files docs
161
%dir %{_datadir}/gtk-doc
162
%dir %{_datadir}/gtk-doc/html
163
%{_datadir}/gtk-doc/html/gladeui-2
164
165
%changelog
166