File certmonger.spec of Package certmonger
125
1
#
2
# spec file for package certmonger
3
#
4
# Copyright (c) 2020 SUSE LLC
5
# Copyright (c) 2020 Stasiek Michalski <stasiek@michalski.cc>.
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
# Please submit bugfixes or comments via https://bugs.opensuse.org/
17
#
18
19
20
Name: certmonger
21
Version: 0.79.11
22
Release: 0
23
Summary: Certificate status monitor and PKI enrollment client
24
License: GPL-3.0-or-later
25
26
URL: http://pagure.io/certmonger/
27
Source0: http://releases.pagure.org/certmonger/certmonger-%{version}.tar.gz
28
Patch0002: 0002-certmonger-return-type.patch
29
30
BuildRequires: autoconf
31
BuildRequires: automake
32
BuildRequires: dbus-1
33
BuildRequires: dbus-1-devel
34
BuildRequires: diffutils
35
BuildRequires: dos2unix
36
BuildRequires: expect
37
BuildRequires: gcc
38
BuildRequires: gettext-devel
39
BuildRequires: krb5-devel
40
BuildRequires: libcurl-devel
41
BuildRequires: libfreebl3-hmac
42
BuildRequires: libidn2-devel
43
BuildRequires: libsoftokn3-hmac
44
BuildRequires: libtalloc-devel
45
BuildRequires: libtevent-devel
46
BuildRequires: libuuid-devel
47
BuildRequires: libxml2-devel
48
BuildRequires: mozilla-nspr-devel
49
BuildRequires: mozilla-nss-devel
50
BuildRequires: mozilla-nss-sysinit
51
BuildRequires: mozilla-nss-tools
52
BuildRequires: openldap2-devel
53
BuildRequires: openssl
54
BuildRequires: openssl-devel
55
BuildRequires: popt-devel
56
BuildRequires: python3-dbus-python
57
BuildRequires: which
58
BuildRequires: xmlrpc-c-devel
59
60
Requires: dbus-1
61
Requires(post): dbus-1
62
Requires(preun): dbus-1
63
Requires(preun): sed
64
65
BuildRequires: systemd-rpm-macros
66
%{?systemd_requires}
67
68
%description
69
Certmonger is a service which is primarily concerned with getting your
70
system enrolled with a certificate authority (CA) and keeping it enrolled.
71
72
%prep
73
%autosetup -p1
74
75
%build
76
autoreconf -i -f
77
%configure \
78
--enable-systemd \
79
--enable-tmpfiles \
80
--with-homedir=/run/certmonger \
81
--with-tmpdir=/run/certmonger --enable-pie --enable-now
82
83
%make_build
84
85
%install
86
%make_install
87
mkdir -p %{buildroot}/%{_localstatedir}/lib/certmonger/{cas,requests}
88
%{find_lang} %{name}
89
90
%check
91
make check
92
93
%pre
94
%service_add_pre certmonger.service
95
96
%post
97
if test $1 -eq 1 ; then
98
%{_bindir}/dbus-send --system --type=method_call --dest=org.freedesktop.DBus / org.freedesktop.DBus.ReloadConfig 2>&1 || :
99
fi
100
%service_add_post certmonger.service
101
%tmpfiles_create certmonger.conf
102
103
%preun
104
%service_del_preun certmonger.service
105
106
%postun
107
%service_del_postun certmonger.service
108
109
%files -f %{name}.lang
110
%doc README.md LICENSE STATUS doc/*.txt
111
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/*
112
%{_datadir}/dbus-1/services/*
113
%dir %{_sysconfdir}/certmonger
114
%config(noreplace) %{_sysconfdir}/certmonger/certmonger.conf
115
%ghost /run/certmonger
116
%{_bindir}/*
117
%{_sbindir}/certmonger
118
%{_mandir}/man*/*
119
%{_libexecdir}/%{name}
120
%{_localstatedir}/lib/certmonger
121
%{_tmpfilesdir}/certmonger.conf
122
%{_datadir}/dbus-1/system-services/*
123
124
%changelog
125