File python-Flask-Babel.spec of Package python-Flask-Babel (Revision b1483d7cd08af9a5cc88e9f19943686a)
Currently displaying revision b1483d7cd08af9a5cc88e9f19943686a , Show latest
90
1
#
2
# spec file for package python-Flask-Babel
3
#
4
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
5
# Copyright (c) 2014 Dr. Axel Braun
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
# Please submit bugfixes or comments via https://bugs.opensuse.org/
17
#
18
19
20
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
21
Name: python-Flask-Babel
22
Version: 0.12.2
23
Release: 1.30
24
Summary: i18n and l10n support for Flask
25
License: BSD-3-Clause
26
Group: Development/Languages/Python
27
URL: https://github.com/python-babel/flask-babel
28
Source: https://files.pythonhosted.org/packages/source/F/Flask-Babel/Flask-Babel-%{version}.tar.gz
29
BuildRequires: %{python_module Babel >= 2.3}
30
BuildRequires: %{python_module Flask}
31
BuildRequires: %{python_module Jinja2 >= 2.5}
32
BuildRequires: %{python_module setuptools}
33
BuildRequires: fdupes
34
BuildRequires: python-rpm-macros
35
Requires: python-Babel >= 2.3
36
Requires: python-Flask
37
Requires: python-Jinja2 >= 2.5
38
BuildArch: noarch
39
%python_subpackages
40
41
%description
42
This module implements i18n and l10n support for Flask. It is based on
43
the Python babel module as well as pytz.
44
45
%prep
46
%setup -q -n Flask-Babel-%{version}
47
48
%build
49
%python_build
50
51
%install
52
%python_install
53
%python_expand %fdupes %{buildroot}%{$python_sitelib}
54
55
%check
56
pushd tests
57
%{python_expand export PYTHONPATH=%{buildroot}%{$python_sitelib}
58
%python_exec tests.py
59
}
60
popd
61
62
%files %{python_files}
63
%license LICENSE
64
%doc README.md
65
%dir %{python_sitelib}/flask_babel
66
%{python_sitelib}/flask_babel/*
67
%{python_sitelib}/Flask_Babel-%{version}-py*.egg-info
68
69
%changelog
70
* Sun Nov 4 2018 jengelh@inai.de
71
- Use noun phrase.
72
* Tue Oct 30 2018 arun@gmx.de
73
- specfile:
74
* update copyright year
75
* remove devel from noarch
76
* be more specific in %%files section
77
* add README.md
78
- update to version 0.12.2:
79
* Switch to using README.md for project description on pypi.
80
* Fix heading underline in index.rst
81
* Thu Aug 31 2017 toddrme2178@gmail.com
82
- Update to 0.11.2
83
* No upstream changelog
84
- Implement single-spec version
85
* Thu Sep 15 2016 toddrme2178@gmail.com
86
- Update to 0.11.1
87
* No upstream changelog
88
* Thu Oct 23 2014 axel.braun@gmx.de
89
- initial OBS build
90