File ibmswtpm2.spec of Package ibmswtpm2 (Revision 6b52fe6ad60cb277e30ede5eef49a63f)
Currently displaying revision 6b52fe6ad60cb277e30ede5eef49a63f , Show latest
89
1
#
2
# spec file for package ibmswtpm2
3
#
4
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
%define suite ibmtss
20
21
Name: ibmswtpm2
22
Version: 1119
23
Release: 1.14
24
Summary: IBM's Software TPM 2.0
25
License: BSD-3-Clause
26
Group: Development/Tools/Other
27
Url: https://sourceforge.net/projects/ibmswtpm2
28
Source: https://sourceforge.net/projects/ibmswtpm2/files/ibmtpm%{version}.tar.gz
29
Patch1: makefile.patch
30
%ifarch ppc ppc64 s390 s390x
31
%define extra_ccflags -DBIG_ENDIAN_TPM=1
32
%else
33
%define extra_ccflags ""
34
%endif
35
BuildRequires: libopenssl-devel >= 1.0
36
BuildRoot: %{_tmppath}/%{name}-%{version}-build
37
38
%description
39
An implementation of the TCG TPM 2.0 specification. It is based on
40
the TPM specification Parts 3 and 4 source code donated by Microsoft,
41
with additional files to complete the implementation.
42
43
This TPM emulator listens on TCP ports (default 2321 and 2322) and
44
saves state to the file "NVChip" in the current directory.
45
46
It is probably not of much use other than testing the IBM TSS
47
implementation because of this specific interface.
48
49
%prep
50
%setup -c -q
51
%patch1 -p 1
52
53
%build
54
cd src
55
CCFLAGS="%{optflags} "%{extra_ccflags} make %{?_smp_mflags}
56
57
%install
58
cd src
59
install -m 755 -D -t %{buildroot}/%{_libexecdir}/%{suite} tpm_server
60
61
%files
62
%defattr(-,root,root)
63
%dir %{_libexecdir}/%{suite}
64
%{_libexecdir}/%{suite}/tpm_server
65
%doc ibmtpm.doc
66
67
%changelog
68
* Thu Jan 18 2018 msuchanek@suse.com
69
- Enable bigendian build
70
* Tue Jan 16 2018 vcizek@suse.com
71
- Update to upstream version 1119
72
* adds openssl 1.1 support (bsc#1066916)
73
- drop patches (upstream):
74
* bits.patch
75
* fix_unreferenced_macro-gcc7.patch
76
* Wed Nov 8 2017 msuchanek@suse.com
77
- Update to upstream version 974
78
- deal with openssl 1.0 vs 1.1 split (bsc#1066916)
79
* Mon Jun 5 2017 msuchanek@suse.com
80
- fix build with gcc7: fix_unreferenced_macro-gcc7.patch
81
* Tue Feb 14 2017 msuchanek@suse.com
82
- Drop a pointer cast hack in bits.patch. It builds without the hack.
83
* Wed Feb 8 2017 jengelh@inai.de
84
- Wrap description, drop empty scriptlets.
85
* Fri Jan 27 2017 msuchanek@suse.com
86
- Import version 832 (FATE#321601)
87
- bits.patch: handle some 32/64bit issues
88
- makefile.patch: some compiler flag adjustments
89