File libvisual.spec of Package libvisual
135
1
#
2
# spec file for package libvisual
3
#
4
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via http://bugs.opensuse.org/
16
#
17
18
19
Name: libvisual
20
BuildRequires: freeglut-devel
21
BuildRequires: gcc-c++
22
BuildRequires: libdrm-devel
23
BuildRequires: libtool
24
BuildRequires: pkgconfig
25
Version: 0.4.0
26
Release: 0
27
# bug437293
28
%ifarch ppc64
29
Obsoletes: libvisual-64bit
30
%endif
31
#
32
Summary: Sound Visualization Library
33
License: GPL-2.0+ and LGPL-2.1+
34
Group: Productivity/Multimedia/Sound/Visualization
35
Url: http://localhost.nl/~synap/libvisual-wiki/index.php/Main_Page
36
BuildRoot: %{_tmppath}/%{name}-%{version}-build
37
Source: %name-%{version}.tar.bz2
38
Source2: baselibs.conf
39
Patch: %name-%{version}.diff
40
Patch1: %name-%{version}-compiler_warnings.diff
41
Patch2: libvisual.visual_cpu_get_altivec.patch
42
Patch3: %name-%{version}-unref-static.diff
43
Patch4: libvisual-0.4.0-2.1-nmu.diff
44
Patch5: libvisual-0.4.0-inlinedefineconflict.patch
45
46
%description
47
Libvisual is a library that acts as a middle layer between applications
48
that need audio visualization and audio visualization plug-ins.
49
50
51
52
Authors:
53
--------
54
Dennis Smit <synap@nerds-incorporated.org>
55
Duilio J. Protti <dprotti@users.sourceforge.net>
56
Vitaly V. Bursov <vitalyb@mail333.com>
57
Gustavo Sverzut Barbieri <gsbarbieri@yahoo.com.br>
58
59
%package devel
60
Summary: sound visualisation library
61
Group: Productivity/Multimedia/Sound/Visualization
62
Requires: %{name} = %{version}
63
Requires: glibc-devel
64
# bug437293
65
%ifarch ppc64
66
Obsoletes: libvisual-devel-64bit
67
%endif
68
#
69
70
%description devel
71
Libvisual is a library that acts as a middle layer between applications
72
that want audio visualisation and audio visualisation plugins.
73
74
This library is used by amaroK for example.
75
76
77
78
Authors:
79
--------
80
Dennis Smit <synap@nerds-incorporated.org>
81
Duilio J. Protti <dprotti@users.sourceforge.net>
82
Vitaly V. Bursov <vitalyb@mail333.com>
83
Gustavo Sverzut Barbieri <gsbarbieri@yahoo.com.br>
84
85
%prep
86
%setup -q
87
%patch
88
%patch1
89
%patch2 -p1
90
%patch3
91
%patch4 -p1
92
%patch5 -p1
93
94
%build
95
autoreconf -fiv
96
%if %suse_version > 1000
97
CFLAGS="$RPM_OPT_FLAGS -fstack-protector"
98
%endif
99
%ifarch %ix86
100
CFLAGS="$RPM_OPT_FLAGS -mmmx"
101
%else
102
CFLAGS="$RPM_OPT_FLAGS"
103
%endif
104
export CFLAGS="$CFLAGS -fno-strict-aliasing"
105
%configure --disable-static --with-pic
106
%{__make} %{?jobs:-j%jobs}
107
108
%install
109
make DESTDIR=$RPM_BUILD_ROOT install
110
mkdir -p $RPM_BUILD_ROOT%_libdir/%name/{morph,input,actor,transform} $RPM_BUILD_ROOT%_datadir/%name/{morph,input,actor,transform}
111
sed -e 's, -L%{_builddir}/libvisual-%{version}/libvisual , ,' $RPM_BUILD_ROOT/%_libdir/libvisual-0.4.la > $RPM_BUILD_ROOT/%_libdir/libvisual-0.4.la.1
112
mv $RPM_BUILD_ROOT/%_libdir/libvisual-0.4.la.1 $RPM_BUILD_ROOT/%_libdir/libvisual-0.4.la
113
# *fixme*
114
rm -rf $RPM_BUILD_ROOT/%_datadir/locale
115
116
%post -p /sbin/ldconfig
117
118
%postun -p /sbin/ldconfig
119
120
%files
121
%defattr(-,root,root)
122
%doc AUTHORS README ChangeLog NEWS TODO COPYING
123
%_libdir/libvisual-0.4.so.*
124
%_libdir/libvisual
125
%_datadir/libvisual
126
127
%files devel
128
%defattr(-,root,root)
129
/usr/include/libvisual-0.4
130
%_libdir/pkgconfig/libvisual-0.4.pc
131
%_libdir/libvisual-0.4.so
132
%_libdir/libvisual-0.4.la
133
134
%changelog
135